summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRobert Falkenberg2022-03-26 08:29:04 +0100
committerRobert Falkenberg2022-03-26 08:29:04 +0100
commit8238ad668de4489745ed08d82729d675eef59cf0 (patch)
tree702bffa3f0d516ba1e388e488f14cf87f96d891e /PKGBUILD
parent33831d06a6b6a95eecae7368766206354e8351d0 (diff)
downloadaur-8238ad668de4489745ed08d82729d675eef59cf0.tar.gz
Add printw-args patch.
Source: https://github.com/EttusResearch/uhd/commit/f665c585ee9ea7beec8de94a4d402190225ccf23
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2384a084fe7b..53aab4fcdc02 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=libuhd3
pkgver=3.15.0.0
-pkgrel=3
+pkgrel=4
pkgdesc="Universal Software Radio Peripheral (USRP) userspace driver"
arch=('x86_64')
url="https://files.ettus.com/manual/"
@@ -19,11 +19,13 @@ conflicts=('libuhd>3.15.0.0' 'libuhd-firmware>3.15.0.0')
source=("libuhd-$pkgver.tar.gz::https://github.com/EttusResearch/uhd/archive/v$pkgver.tar.gz"
"boost-1.73.patch"
"gcc-11.1.patch"
- "boost-1.76.patch")
+ "boost-1.76.patch"
+ "printw-args.patch")
sha256sums=('eed4a77d75faafff56be78985950039f8d9d1eb9fcbd58b8862e481dd49825cd'
'10c2f221dee97418f92d10606f9b9fea1436e3bd0d7120e7b24fc90a95a07fc1'
'ccac8a77ffe3c9421076aa3c94ffc1aa92bb4f60de4eec3aec6431446e01db9e'
- '84365baed4645a7cd0be1f97b896e3e0274eb1cbcfece1afbe9e41555fa1881c')
+ '84365baed4645a7cd0be1f97b896e3e0274eb1cbcfece1afbe9e41555fa1881c'
+ '4ba9064f359268a434f53de489693d6430d62938542a9f145dd16588f85b5a48')
prepare() {
cd "$srcdir/uhd-$pkgver"
@@ -39,6 +41,11 @@ prepare() {
# Fix missing/misplaced include for boost::math::sign
# as emerge since Boost 1.76
patch --forward --strip=1 --input "$srcdir/boost-1.76.patch"
+
+ # Fix printw function arguments
+ # This is necessary when compiling with -Werror=format-security as Debian
+ # package builds do.
+ patch --forward --strip=1 --input "$srcdir/printw-args.patch"
cd "$srcdir/uhd-$pkgver/host"
mkdir build
@@ -53,6 +60,7 @@ build() {
-DENABLE_UTILS=ON \
-DENABLE_TESTS=OFF \
-DENABLE_E100=ON \
+ -DCMAKE_VERBOSE_MAKEFILE:BOOL=ON \
-DENABLE_E300=ON
make -C "build"
}