summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJay Ta'ala2020-09-01 08:29:32 +1000
committerJay Ta'ala2020-09-01 08:29:32 +1000
commit29987c3764aa7338876480f9401a41d70064b253 (patch)
treef6b86bce9879d2c6a7358cab1aa866a7192e751a /PKGBUILD
parent90ccaebdc84bac6e2ef9bd5d461ed27822acf0d7 (diff)
downloadaur-29987c3764aa7338876480f9401a41d70064b253.tar.gz
Upstream pkgname has changed so update this PKGBUILD to reference the
new name and github location.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 24249dea9481..55dec1bc725f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,9 @@
# Contributor: Bradley Kennedy <bk@co60.ca>
pkgname=libuiohook
+newname=uiohook
pkgver=1.0.3
-pkgrel=3
+pkgrel=4
pkgdesc="A multi-platform C library to provide global input/ouput hooking from userland."
arch=('i686' 'x86_64')
url="https://github.com/kwhat/libuiohook"
@@ -13,17 +14,17 @@ depends=("libxt" "libxtst" "libxinerama")
makedepends=() # All included in base-devel
optdepends=()
conflicts=()
-source=("https://github.com/kwhat/$pkgname/archive/${pkgver}.zip")
-sha256sums=('a7bfdf7377223bf3c46b0028fa44e6070a009bfbd2e1111c506b777c8cf48e7d')
+source=("https://github.com/kwhat/$newname/archive/${pkgver}.zip")
+sha256sums=('e972be653e303838354781209798ec0ad2ff1e416c62cf20db6f1cf2ba1ef604')
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$newname-$pkgver"
./bootstrap.sh
./configure --prefix=/usr --libexecdir=/usr/lib --without-libsigsegv
make
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$newname-$pkgver"
make DESTDIR="$pkgdir" install
}