summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAntonio Cardace2015-10-01 14:00:46 +0200
committerAntonio Cardace2015-10-01 14:00:46 +0200
commit613f3eea2f4f2c5e2889d675c76f43690cd9bf13 (patch)
treed29fab82b739d1322068925220e7705dac2fed7d /PKGBUILD
parent868c8e2234313234e007cb30e73eb3049cf774f8 (diff)
downloadaur-613f3eea2f4f2c5e2889d675c76f43690cd9bf13.tar.gz
now gets the source and compiles
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 24 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index da0c86d02498..f5b04bcf3efd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,24 +3,40 @@ pkgname=libumlib0
pkgver=0.8.2
pkgrel=1
pkgdesc="Library with common functions used by every UMView module."
-arch=('x86_64')
+arch=('i686' 'x86_64')
url="https://sourceforge.net/projects/view-os"
license=('GPL2')
depends=('glibc>=2.4')
+makedepends=('autoconf' 'automake' 'make' 'libtool')
provides=("$pkgname=$pkgver")
conflicts=("$pkgname")
replaces=("$pkgname")
install="${pkgname}.install"
-source=("http://ftp.us.debian.org/debian/pool/main/u/umview/libumlib0_0.8.2-1.1_amd64.deb"
- "${pkgname}.install")
-md5sums=("28edfce5ed77824603fbf0742a790e78"
- "b4165e6142a92d65c8e14479486decc4")
+source=("http://http.debian.net/debian/pool/main/u/umview/umview_0.8.2.orig.tar.gz"
+ "${pkgname}.install"
+ "${pkgname}.diff"
+ "http://ftp.us.debian.org/debian/pool/main/u/umview/libumlib0_0.8.2-1.1_i386.deb")
+md5sums=("ac6d6baeb5700943ecf5021d980ceb7d"
+ "b4165e6142a92d65c8e14479486decc4"
+ "c3c17eafbb532433d49e37f9cfabbed7"
+ "7fb63081024db1b749e24cb19416ff66")
prepare() {
- cd "$srcdir"
- tar -xf data.tar.xz
+ cd $srcdir
+ patch -i ${pkgname}.diff umview-${pkgver}/Makefile.am
+}
+
+build(){
+ cd "$srcdir/umview-${pkgver}"
+ autoreconf -i
+ ./configure --prefix="${pkgdir}/usr" --disable-static
+ make
}
package() {
- cp -r "${srcdir}/usr" "$pkgdir"
+ mkdir -p ${pkgdir}/usr/share
+ tar -xf data.tar.xz
+ cp -r usr/share ${pkgdir}/usr/
+ cd "$srcdir/umview-${pkgver}"
+ make install &> /dev/null
}