summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndrew Sun2019-03-27 16:03:43 -0400
committerAndrew Sun2019-03-27 16:03:43 -0400
commit06405023e8d2a51cd353c42c26b4a4a5519f38bb (patch)
treecaa14686d4dfe86378694dbd0ed893c26de53cb8 /PKGBUILD
parentcccfc73046e62a3c1307e253d67a460a414c2ddb (diff)
downloadaur-06405023e8d2a51cd353c42c26b4a4a5519f38bb.tar.gz
libunity: use latest source tarball
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d3e75f808ac0..0df19812d964 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,19 +5,24 @@
pkgname=libunity
pkgver=7.1.4
-pkgrel=7
+pkgrel=8
pkgdesc='Library for instrumenting and integrating with all aspects of the Unity shell'
arch=('i686' 'x86_64')
url='https://launchpad.net/libunity'
license=('LGPL')
depends=('dee' 'gtk3' 'libdbusmenu-glib')
makedepends=('gnome-common' 'gobject-introspection' 'intltool' 'vala')
-source=("https://launchpad.net/ubuntu/+archive/primary/+files/${pkgname}_${pkgver}+18.04.20180209.1.orig.tar.gz")
-sha256sums=("a6f3a6f6ef5536398b207b31ffed0747b7a9916512a71656d3c1d7e129acf15f")
+source=("https://launchpad.net/ubuntu/+archive/primary/+files/${pkgname}_${pkgver}+19.04.20190319.orig.tar.gz")
+sha256sums=('56ecb380d74bf74caba193d9e8ad6b0c85ccf9eeb461bc9731c2b8636e1f1492')
+
+prepare() {
+ cd "${srcdir}"
+ NOCONFIGURE=1 ./autogen.sh
+}
build() {
cd "${srcdir}"
- ./autogen.sh --prefix='/usr' --sysconfdir='/etc' --localstatedir='/var' --disable-static
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --disable-static
make
}