summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2020-05-20 14:04:20 -0600
committerMark Wagie2020-05-20 14:04:20 -0600
commit17a6e1993bf15202019fe331c630f65fa80618d0 (patch)
treec2b1211cb3627c2dd887d14227f97904832f780b /PKGBUILD
parent871a8f9e4e7108fbdd966151e6c1342819b383cb (diff)
downloadaur-17a6e1993bf15202019fe331c630f65fa80618d0.tar.gz
update Maintainer
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 8 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f0fa30abbdcd..ea1424849912 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Alex Dewar <alex.dewar@gmx.co.uk>
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Contributor: Alex Dewar <alex.dewar@gmx.co.uk>
# Contributor: Andrew Sun <adsun701@gmail.com>
# Contributor: John Jenkins <twodopeshaggy@gmail.com>
# Contributor: Maxime Gauduin <alucryd@gmail.com>
@@ -9,7 +10,7 @@ pkgver=7.1.4
pkgrel=9
pkgdesc='Library for instrumenting and integrating with all aspects of the Unity shell'
arch=('i686' 'x86_64')
-url='https://launchpad.net/libunity'
+url="https://launchpad.net/libunity"
license=('LGPL')
depends=('dee' 'gtk3' 'libdbusmenu-glib')
makedepends=('gnome-common' 'gobject-introspection' 'intltool' 'vala')
@@ -19,18 +20,15 @@ sha256sums=('56ecb380d74bf74caba193d9e8ad6b0c85ccf9eeb461bc9731c2b8636e1f1492'
'98a2562dcf3b3a864d1c05331b4dc672d8bff4b592ca796a0bc132a416f33262')
prepare() {
- cd "${srcdir}"
- patch -p1 < 0001-Fix-FTB-with-recent-vala-requiring-non-public-abstra.patch
- NOCONFIGURE=1 ./autogen.sh
- ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --disable-static
+ patch -p1 < 0001-Fix-FTB-with-recent-vala-requiring-non-public-abstra.patch
+ NOCONFIGURE=1 ./autogen.sh
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --disable-static
}
build() {
- cd "${srcdir}"
- make
+ make
}
package() {
- cd "${srcdir}"
- make DESTDIR="${pkgdir}" install
+ make DESTDIR="$pkgdir" install
}