summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJohn ShaggyTwoDope Jenkins2015-06-23 01:35:52 -0700
committerJohn ShaggyTwoDope Jenkins2015-06-23 01:35:52 -0700
commit4a83db795065a39f5485a08f00b31ba20d0fcf09 (patch)
treeacdd9f7c863c5f5005b73eaf8ae3bcc834fd6b13 /PKGBUILD
downloadaur-4a83db795065a39f5485a08f00b31ba20d0fcf09.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4aed4605a678
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: John Jenkins <twodopeshaggy@gmail.com>
+# Contributor: Maxime Gauduin <alucryd@gmail.com>
+# Contributor: Balló György <ballogyor+arch@gmail.com>
+
+pkgname=libunity
+pkgver=7.1.4
+pkgrel=1
+pkgdesc='Library for instrumenting and integrating with all aspects of the Unity shell'
+arch=('i686' 'x86_64')
+url='https://launchpad.net/libunity'
+license=('LGPL')
+depends=('dee' 'gtk3' 'libdbusmenu-glib')
+makedepends=('bzr' 'gnome-common' 'gobject-introspection' 'intltool' 'vala')
+install="${pkgname}.install"
+source=("${pkgname}-${pkgver}::bzr+lp:${pkgname}#revision=312")
+sha256sums=('SKIP')
+
+build() {
+ cd ${pkgname}-${pkgver}
+ find . -type f -exec sed -i 's/ListStore/Gtk.ListStore/' {} \;
+ ./autogen.sh --prefix='/usr' --sysconfdir='/etc' --localstatedir='/var' --disable-static
+ make
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim: ts=2 sw=2 et: