summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndrew Sun2018-10-07 09:17:50 -0400
committerAndrew Sun2018-10-07 09:17:50 -0400
commitcccfc73046e62a3c1307e253d67a460a414c2ddb (patch)
tree9911803b00a870169ae8ea3a1ce088743e80484f /PKGBUILD
parent3224f3c34635bc85fee24af4f5b184824672ca57 (diff)
downloadaur-cccfc73046e62a3c1307e253d67a460a414c2ddb.tar.gz
libunity: use latest source tarball
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5c1509866ffb..d3e75f808ac0 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,27 @@
-# Maintainer: John Jenkins <twodopeshaggy@gmail.com>
+# Maintainer: Andrew Sun <adsun701@gmail.com>
+# Contributor: John Jenkins <twodopeshaggy@gmail.com>
# Contributor: Maxime Gauduin <alucryd@gmail.com>
# Contributor: Balló György <ballogyor+arch@gmail.com>
pkgname=libunity
pkgver=7.1.4
-pkgrel=6
+pkgrel=7
pkgdesc='Library for instrumenting and integrating with all aspects of the Unity shell'
arch=('i686' 'x86_64')
url='https://launchpad.net/libunity'
license=('LGPL')
depends=('dee' 'gtk3' 'libdbusmenu-glib')
makedepends=('gnome-common' 'gobject-introspection' 'intltool' 'vala')
-source=("https://launchpad.net/ubuntu/+archive/primary/+files/libunity_$pkgver+17.10.20170605.orig.tar.gz")
-md5sums=('0fc16e278838e6f6f46a4f7433df07a8')
+source=("https://launchpad.net/ubuntu/+archive/primary/+files/${pkgname}_${pkgver}+18.04.20180209.1.orig.tar.gz")
+sha256sums=("a6f3a6f6ef5536398b207b31ffed0747b7a9916512a71656d3c1d7e129acf15f")
build() {
- cd ${srcdir}
+ cd "${srcdir}"
./autogen.sh --prefix='/usr' --sysconfdir='/etc' --localstatedir='/var' --disable-static
make
}
package() {
- cd ${srcdir}
+ cd "${srcdir}"
make DESTDIR="${pkgdir}" install
}