summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChocobo12018-12-31 13:21:10 +0800
committerChocobo12018-12-31 13:21:10 +0800
commitb1145d46d079e2a5b039d192a7f9fb389bf74998 (patch)
tree0181d55ccc749dc0851573e65f57c50a3cbf6ef8 /PKGBUILD
parent1da02273f0e863203735797a3c0779d837a816e9 (diff)
downloadaur-b1145d46d079e2a5b039d192a7f9fb389bf74998.tar.gz
upgpkg: libupnp-git 1.8.4.r18.gb3f55df-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0f8e91aac1ef..9cc496348889 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=libupnp-git
-pkgver=1.8.2.r12.gf07f078
+pkgver=1.8.4.r18.gb3f55df
pkgrel=1
pkgdesc="Portable open source UPnP development kit"
arch=('i686' 'x86_64')
@@ -12,18 +12,18 @@ makedepends=('git')
provides=('libupnp')
conflicts=('libupnp')
options=('staticlibs')
-source=("git+https://git.code.sf.net/p/pupnp/code")
+source=("git+https://github.com/mrjimenez/pupnp.git")
sha256sums=('SKIP')
pkgver() {
- cd "code"
+ cd "pupnp"
git describe --long --tags | sed 's/^release-//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "code"
+ cd "pupnp"
./bootstrap
./configure --prefix="/usr"
@@ -31,14 +31,14 @@ build() {
}
check() {
- cd "code"
+ cd "pupnp"
- #make check
+ make check
}
package() {
- cd "code"
+ cd "pupnp"
make DESTDIR="$pkgdir" install
- install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/libupnp/LICENSE"
+ install -Dm644 "COPYING" "$pkgdir/usr/share/licenses/libupnp/COPYING"
}