summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGAZDOWN2019-03-19 18:01:52 +0100
committerGAZDOWN2019-03-19 18:06:26 +0100
commit6ec22064fae2a5e68618a93e1ff5bf146a755691 (patch)
treefcb7d7faba27cc711bce3f107bd64e0550569c32 /PKGBUILD
parentcb6def5a33f63e4a557073764dcbc13df64dcbef (diff)
downloadaur-6ec22064fae2a5e68618a93e1ff5bf146a755691.tar.gz
added cflags & 32bit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 15 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 19843fcf6e21..b27dfed06711 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgname=libupnp18
_pkgname=libupnp
pkgver=1.8.4
_pkgver=1.8
-pkgrel=3
+pkgrel=4
pkgdesc='A separate installation of libupnp 1.8 branch'
url='http://pupnp.sourceforge.net/'
arch=('x86_64')
@@ -22,11 +22,20 @@ prepare() {
build() {
cd ${_pkgname}-${pkgver}
- ./configure \
- --prefix=/usr \
- --enable-reuseaddr \
- --libdir=/usr/lib/libupnp-${_pkgver} \
- --includedir=/usr/include/${_pkgname}-${_pkgver}
+
+ if [ "${arch}" == "x86" ]; then
+ CFLAGS+=' -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE' ./configure \
+ --prefix=/usr \
+ --enable-reuseaddr \
+ --libdir=/usr/lib/libupnp-${_pkgver} \
+ --includedir=/usr/include/${_pkgname}-${_pkgver}
+ else
+ ./configure \
+ --prefix=/usr \
+ --enable-reuseaddr \
+ --libdir=/usr/lib/libupnp-${_pkgver} \
+ --includedir=/usr/include/${_pkgname}-${_pkgver}
+ fi
make
}