summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGAZDOWN2019-03-19 19:12:52 +0100
committerGAZDOWN2019-03-19 19:12:52 +0100
commit904a98ecc4758d42d514ef64a5e551248248ba1f (patch)
treeceebbb9f8ea6151fb2ecd468c47bf948b62be740 /PKGBUILD
parent6ec22064fae2a5e68618a93e1ff5bf146a755691 (diff)
downloadaur-904a98ecc4758d42d514ef64a5e551248248ba1f.tar.gz
added cflags from all arches
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 5 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b27dfed06711..e570f47c50cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,19 +23,11 @@ prepare() {
build() {
cd ${_pkgname}-${pkgver}
- if [ "${arch}" == "x86" ]; then
- CFLAGS+=' -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE' ./configure \
- --prefix=/usr \
- --enable-reuseaddr \
- --libdir=/usr/lib/libupnp-${_pkgver} \
- --includedir=/usr/include/${_pkgname}-${_pkgver}
- else
- ./configure \
- --prefix=/usr \
- --enable-reuseaddr \
- --libdir=/usr/lib/libupnp-${_pkgver} \
- --includedir=/usr/include/${_pkgname}-${_pkgver}
- fi
+ CFLAGS+=' -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE' ./configure \
+ --prefix=/usr \
+ --enable-reuseaddr \
+ --libdir=/usr/lib/libupnp-${_pkgver} \
+ --includedir=/usr/include/${_pkgname}-${_pkgver}
make
}