summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authortristelune12015-06-26 18:35:21 +0200
committertristelune12015-06-26 18:35:21 +0200
commit5c38bb02867ba82cde88490e10fd1b16641132a5 (patch)
treefd9609cae655ff7642c4c6dda854c845a1395743 /PKGBUILD
downloadaur-5c38bb02867ba82cde88490e10fd1b16641132a5.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..03cc120cf3da
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Tristelune <tristelune at archlinux dot info>
+pkgname=libupnpp
+pkgver=0.10.0
+pkgrel=1
+pkgdesc="A C++ wrapper for libupnp - used with upmpdcli or upplay"
+url="http://www.lesbonscomptes.com/upplay/downloads.html"
+arch=('x86_64' 'i686')
+license=('GPL2')
+depends=('libupnp' 'expat' 'curl')
+source=("http://www.lesbonscomptes.com/upmpdcli/downloads/${pkgname}-${pkgver}.tar.gz")
+md5sums=('02f583f7ae0d95358710d4eb0c342fba')
+
+
+build(){
+ cd "${pkgname}-${pkgver}"
+ ./configure --prefix=/usr
+ make
+}
+
+package(){
+ cd "${pkgname}-${pkgver}"
+ make DESTDIR="$pkgdir" install
+}