summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorovf2019-11-05 12:37:55 +0000
committerovf2019-11-05 12:37:55 +0000
commit3aefdaf148804d127f33353a45c78ff10239d558 (patch)
treec23b0073b46c09d59a68515d22a988726058f281 /PKGBUILD
downloadaur-3aefdaf148804d127f33353a45c78ff10239d558.tar.gz
liburing-0.2-1: new package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c58fc245c280
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: ovf <ovf@mm.st>
+pkgname=liburing
+pkgver=0.2
+pkgrel=1
+pkgdesc="Linux-native io_uring I/O access library (git-version)"
+arch=(i686 x86_64)
+url="http://git.kernel.dk/cgit/liburing/"
+license=('LGPL2.1')
+provides=(liburing.so)
+conflicts=(liburing.so)
+source=("https://git.kernel.dk/cgit/liburing/snapshot/liburing-$pkgver.tar.bz2")
+md5sums=('8998f15d94a9f83e2d82ef2e58037404')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure
+ make
+}
+
+package() {
+ pwd
+ cd "$srcdir/$pkgname-$pkgver"
+ DESTDIR="$pkgdir/" make install
+}