summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChocobo12021-08-28 22:55:20 +0800
committerChocobo12021-08-28 22:55:20 +0800
commit23301f74f58db4605cd616baa9a8574bbc312fe2 (patch)
tree442d2b8deddaa173bd68e5a0aa38c41604fd879f /PKGBUILD
parent402a1892f284e35c200f12093850b874649ee5b4 (diff)
downloadaur-23301f74f58db4605cd616baa9a8574bbc312fe2.tar.gz
upgpkg: libusb-git 1.0.24.r66.g1a906274-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 68896f4019ad..827c5b4bc32a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=libusb-git
-pkgver=1.0.24.rc1.r0.g42ad1d1d
+pkgver=1.0.24.r66.g1a906274
pkgrel=1
pkgdesc="A cross-platform library to access USB devices"
arch=('i686' 'x86_64')
@@ -19,7 +19,10 @@ sha256sums=('SKIP')
pkgver() {
cd "libusb"
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ _tag=$(git tag -l --sort -v:refname | sed '/rc[0-9]*/d' | head -n1)
+ _rev=$(git rev-list --count $_tag..HEAD)
+ _hash=$(git rev-parse --short HEAD)
+ printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash" | sed 's/^v//'
}
build() {