summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2018-09-02 15:24:40 +0000
committerDaniel Bermond2018-09-02 15:24:40 +0000
commitd9ab7d918776ba977328ba0c1790f1cd64cacc47 (patch)
tree8003db95191d5a1ae23a98894b73e833b677c0dc /PKGBUILD
parent3d121c4cc2bc53bb7ac2b727a935c1b6e39ce08d (diff)
downloadaur-d9ab7d918776ba977328ba0c1790f1cd64cacc47.tar.gz
Switch to meson build system
This change was also applied on the official repository package. References ---------- https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/libva&id=04d815f130c474b018d18c0696b65a3033083060
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 7 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3dad2ecd48ae..5866cd18819e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Daniel Bermond < yahoo-com: danielbermond >
pkgname=libva-git
-pkgver=2.0.0.r44.g68a4bef
-pkgrel=2
+pkgver=2.2.1.pre1.20180831.r0.gb6c50da
+pkgrel=1
pkgdesc='Video Acceleration (VA) API for Linux (git version)'
arch=('i686' 'x86_64')
url='https://01.org/linuxmedia/vaapi/'
license=('MIT')
-depends=('glibc' 'libdrm' 'libgl' 'libx11' 'libxext' 'libxfixes' 'wayland')
-makedepends=('git' 'mesa')
+depends=('libdrm' 'libgl' 'libx11' 'libxext' 'libxfixes' 'wayland')
+makedepends=('git' 'libglvnd' 'mesa' 'meson')
optdepends=('libva-vdpau-driver: backend for Nvidia and AMD cards'
'libva-intel-driver: backend for Intel cards')
provides=('libva' 'libva-drm.so' 'libva-glx.so' 'libva-wayland.so'
@@ -27,15 +27,14 @@ pkgver() {
build() {
cd "$pkgname"
- ./autogen.sh
- ./configure --prefix='/usr'
- make
+ arch-meson . build
+ ninja -C build
}
package() {
cd "$pkgname"
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" ninja -C build install
install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}