summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndre Vallestero2020-02-14 20:02:31 -0500
committerAndre Vallestero2020-02-14 20:02:31 -0500
commit16d8e51aef0714b37d29920f00b31f330e1712d0 (patch)
tree2ae3b7e7868b44faf313b9552303f7e8afe52635 /PKGBUILD
downloadaur-libva-hantro-h264-git.tar.gz
Added hanro h264 support based on ph5 fork
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ae3085cb4814
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Andre Vallestero < gmail-com: andrevallestero >
+
+pkgname=libva-hantro-h264-git
+_srcname=libva
+pkgver=r1580.0b8a288
+pkgrel=1
+pkgdesc='Video Acceleration (VA) API for Linux (Hantro H264 support, git version)'
+arch=('aarch64')
+url='https://github.com/pH5/libva/tree/hantro-h264'
+license=('MIT')
+depends=('libdrm' 'libgl' 'libx11' 'libxext' 'libxfixes' 'wayland')
+makedepends=('git' 'libglvnd' 'mesa' 'meson')
+optdepends=('libva-vdpau-driver: backend for Nvidia and AMD cards'
+ 'libva-intel-driver: backend for Intel cards')
+provides=('libva' 'libva-drm.so' 'libva-glx.so' 'libva-wayland.so'
+ 'libva-x11.so' 'libva.so')
+conflicts=('libva')
+source=('git+https://github.com/pH5/libva.git#branch=hantro-h264')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_srcname"
+ printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$_srcname"
+ arch-meson . build
+ ninja -C build
+}
+
+package() {
+ cd "$_srcname"
+ DESTDIR="$pkgdir" ninja -C build install
+ install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}