summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2019-06-06 15:37:22 +0000
committerDaniel Bermond2019-06-06 15:42:56 +0000
commitc3158e13152702b84f14af16b9dcaed1cf45f57b (patch)
tree9f3a6b1dcf0abcb073bf675b12aa5050964bccc7 /PKGBUILD
parentd72ede92633843348a4cb2bbab275c9ccfbdc5ea (diff)
downloadaur-c3158e13152702b84f14af16b9dcaed1cf45f57b.tar.gz
Fix build. Fix license. Update dependencies. Cosmetics.
h264enc was renamed upstream to h264encode[1] and no longer needs to be renamed downstream to avoid conflict with openh264. License is MIT[2][3]. References ---------- [1] https://github.com/intel/libva-utils/commit/fbb17203aee1ff3f32a04a5f83e427245457890f [2] https://github.com/intel/libva-utils/blob/fbb17203aee1ff3f32a04a5f83e427245457890f/COPYING [3] https://github.com/intel/libva-utils/blob/fbb17203aee1ff3f32a04a5f83e427245457890f/meson.build#L8
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 7 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f2ca96091177..f8ad83778ac3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,37 @@
# Maintainer: Daniel Bermond < gmail-com: danielbermond >
pkgname=libva-utils-git
-_srcname=libva-utils
-pkgver=2.2.1.pre1.20180921.r5.g375e4ea
+pkgver=2.2.1.pre1.20180921.r15.gfbb1720
pkgrel=1
pkgdesc='Intel VA-API media applications and scripts for libva (git version)'
arch=('i686' 'x86_64')
url='https://github.com/01org/libva-utils/'
-license=('custom')
-depends=('libva')
-makedepends=('git' 'meson' 'mesa')
+license=('MIT')
+depends=('libva' 'libx11' 'wayland')
+makedepends=('git' 'meson' 'libdrm' 'libxext' 'libxfixes')
provides=('libva-utils')
conflicts=('libva-utils')
source=('git+https://github.com/intel/libva-utils.git')
sha256sums=('SKIP')
pkgver() {
- cd "$_srcname"
+ cd libva-utils
# git, tags available
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
}
build() {
- cd "$_srcname"
+ cd libva-utils
arch-meson . build
ninja -C build
}
package() {
- cd "$_srcname"
+ cd libva-utils
DESTDIR="$pkgdir" ninja -C build install
- # avoid conflict with h264enc from package openh264
- mv "${pkgdir}/usr/bin/h264enc" "${pkgdir}/usr/bin/h264enc-libva-utils"
-
install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}