summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2018-12-05 12:45:01 +0000
committerDaniel Bermond2018-12-05 12:45:01 +0000
commitd72ede92633843348a4cb2bbab275c9ccfbdc5ea (patch)
tree85d738b3afaf68fb073ea16bcc1306ef325ac1df /PKGBUILD
parentc06132c73b2091bcea090d32b14ca676b535ea1b (diff)
downloadaur-d72ede92633843348a4cb2bbab275c9ccfbdc5ea.tar.gz
Do not rename the source clone
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d5d1d465f1c8..f2ca96091177 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
-# Maintainer: Daniel Bermond < yahoo-com: danielbermond >
+# Maintainer: Daniel Bermond < gmail-com: danielbermond >
pkgname=libva-utils-git
-pkgver=2.2.0.pre1.r2.g9a10ad6
+_srcname=libva-utils
+pkgver=2.2.1.pre1.20180921.r5.g375e4ea
pkgrel=1
-pkgdesc='Intel VA-API Media Applications and Scripts for libva (git version)'
+pkgdesc='Intel VA-API media applications and scripts for libva (git version)'
arch=('i686' 'x86_64')
url='https://github.com/01org/libva-utils/'
license=('custom')
@@ -11,28 +12,29 @@ depends=('libva')
makedepends=('git' 'meson' 'mesa')
provides=('libva-utils')
conflicts=('libva-utils')
-source=("$pkgname"::'git+https://github.com/intel/libva-utils.git')
+source=('git+https://github.com/intel/libva-utils.git')
sha256sums=('SKIP')
pkgver() {
- cd "$pkgname"
+ cd "$_srcname"
# git, tags available
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
}
build() {
- cd "$pkgname"
+ cd "$_srcname"
arch-meson . build
ninja -C build
}
package() {
- cd "$pkgname"
+ cd "$_srcname"
DESTDIR="$pkgdir" ninja -C build install
+ # avoid conflict with h264enc from package openh264
mv "${pkgdir}/usr/bin/h264enc" "${pkgdir}/usr/bin/h264enc-libva-utils"
install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"