summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuis Martinez2023-03-09 17:10:54 -0600
committerLuis Martinez2023-03-09 17:10:54 -0600
commitd5d93f3e0c66ffc871569a215358fccc0ef96e45 (patch)
tree7e400c69d816fa82c1f8aebacf012d70c2d40fdf /PKGBUILD
parent94512a88276856538fcc56f802496340d98126aa (diff)
downloadaur-libviface-git.tar.gz
fix package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD55
1 files changed, 26 insertions, 29 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3c6f8a1b2ee3..69476517e2a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,38 @@
# Maintainer: Augugrumi <augugrumi@gmail.com>
-pkgname=libviface-git # '-bzr', '-git', '-hg' or '-svn'
-pkgver=v1.1.1
-pkgrel=4
-pkgdesc="Fork of the official libviface package. C++ bindings for Linux tun/tap and netdevice interface."
+
+pkgname=libviface-git
+_pkg="${pkgname%-git}"
+pkgver=r75.4f33d05
+pkgrel=1
+epoch=1
+pkgdesc="C++ bindings for Linux tun/tap and netdevice interface"
arch=('x86_64')
-url="https://github.com/Augugrumi/libviface"
-license=('APACHE')
+url="https://github.com/hpenetworking/libviface"
+license=('Apache')
groups=('linux-tools')
-depends=()
-optdepends=('libtins: packets manipulation'
- 'gcc-libs: additional gcc support')
-makedepends=(git cmake) # 'bzr', 'git', 'mercurial' or 'subversion'
-provides=("${pkgname%-VCS}")
-conflicts=("${pkgname%-VCS}")
-replaces=()
-backup=()
-options=()
-source=("${pkgname%-git}::git://github.com/Augugrumi/libviface.git")
-noextract=()
-md5sums=('SKIP')
-srcdir=()
+depends=('gcc-libs')
+optdepends=('libtins: packets manipulation')
+makedepends=('cmake' 'git')
+provides=("$_pkg=1.1.0")
+conflicts=("$_pkg")
+source=("$_pkg::git+$url")
+sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/${pkgname%-git}"
- printf "%s" "$(git describe --tags)"
+ cd "$_pkg"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd "$srcdir/${pkgname%-git}"
- rm -Rf ./build/
- mkdir ./build/
- cd ./build/
- cmake -DCMAKE_INSTALL_PREFIX=/usr/ ..
- make
+ cmake \
+ -B build \
+ -S "$_pkg" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=None \
+ -Wno-dev
+ cmake --build build
}
package() {
- cd "$srcdir/${pkgname%-git}/build/"
- make DESTDIR="$pkgdir/" install/strip
+ DESTDIR="$pkgdir" cmake --install build
}