summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authors3rj1k2022-06-03 17:25:49 +0300
committers3rj1k2022-06-03 17:25:49 +0300
commitc4b80cf567e02bcc62df71c80bfdcb6d01760f75 (patch)
tree247fa407011222e89fd1c51ebb5980de8f8d9310 /PKGBUILD
downloadaur-c4b80cf567e02bcc62df71c80bfdcb6d01760f75.tar.gz
release 4.0.0-1
Signed-off-by: s3rj1k <evasive.gyron@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD63
1 files changed, 63 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0a9c59901555
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,63 @@
+# Maintainer: s3rj1k <evasive dot gyron at gmail dot com>
+# Do not forget to run `makepkg --printsrcinfo > .SRCINFO`
+
+pkgname=libvirt-glib-vnc
+pkgver=4.0.0
+pkgrel=1
+pkgdesc='Libvirt-Glib runtime libraries and headers exclusively for VNC support.'
+arch=('x86_64')
+url="https://gitlab.com/libvirt/libvirt-glib"
+license=(
+ 'LGPL2.1'
+)
+depends=(
+ 'libcap-ng'
+ 'libvirt-vnc'
+)
+makedepends=(
+ 'gobject-introspection'
+ 'intltool'
+ 'meson'
+ 'python'
+ 'vala'
+)
+conflicts=(
+ 'libvirt-glib'
+)
+source=(
+ "https://libvirt.org/sources/glib/libvirt-glib-${pkgver}.tar.xz"{,'.asc'}
+ "libvirt-glib-meson.build.patch"
+)
+sha256sums=(
+ '8423f7069daa476307321d1c11e2ecc285340cd32ca9fc05207762843edeacbd'
+ 'SKIP'
+ '274acd43b641abfc5b378ad866ac0dad78abd942ac347e2049eefa3ce2e5362c'
+)
+validpgpkeys=(
+ '453B65310595562855471199CA68BE8010084C9C' # Jiří Denemark <jdenemar@redhat.com>
+ 'DAF3A6FDB26B62912D0E8E3FBE86EBB415104FDF' # Daniel P. Berrange <dan@berrange.com>
+)
+
+prepare() {
+ cd "${srcdir}/libvirt-glib-${pkgver}"
+ patch meson.build < "${srcdir}/libvirt-glib-meson.build.patch"
+}
+
+build() {
+ cd "${srcdir}/libvirt-glib-${pkgver}"
+ arch-meson build \
+ --prefix=/usr \
+ --buildtype=plain \
+ --auto-features disabled \
+ -Ddocs=disabled \
+ -Dintrospection=disabled \
+ -Dtests=disabled \
+ -Dvapi=disabled
+
+ ninja -C build
+}
+
+package() {
+ cd "${srcdir}/libvirt-glib-${pkgver}"
+ DESTDIR="${pkgdir}" ninja -C build install
+}