summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGeorge Rawlinson2018-04-24 17:20:25 +1200
committerGeorge Rawlinson2018-04-24 17:20:25 +1200
commitb19157771c0d5b6c90fd5d49a7decb2215cc87ec (patch)
tree8544d22adb6d597d49f146b2dec3701a1a502dc8 /PKGBUILD
downloadaur-b19157771c0d5b6c90fd5d49a7decb2215cc87ec.tar.gz
feat: version 0.5.5
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1d6b9c238e85
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: George Rawlinson <george@rawlinson.net.nz>
+pkgname=libvisio2svg
+pkgver=0.5.5
+pkgrel=1
+pkgdesc="Library/Utilities to convert Microsoft (MS) Visio Documents and Stencils (VSS and VSD) to SVG"
+arch=('x86_64')
+url="https://github.com/kakwa/libvisio2svg"
+license=('GPL')
+depends=('librevenge' 'libvisio' 'libemf2svg' 'libxml2' 'libwmf')
+provides=('libvisio2svg')
+conflicts=('libvisio2svg-git')
+sha512sums=('42b0a66f839885aa46022a6fb9dda40143586a14a0a880eb8af71a749de312f8b6ed00f1c4e2f9e438814dcabb638672a2f2b2d5c85be015ce6ee4dc59ae8765')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/kakwa/libvisio2svg/archive/${pkgver}.tar.gz")
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ cmake . -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}