summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorrevel2015-06-21 15:17:25 +0200
committerrevel2015-06-21 15:17:25 +0200
commit06c8219c46b736ca825f60c25e11ae1fe3fa5cc9 (patch)
tree2d21ee643bdb0c85e57ef6a068715c4dce480bbf /PKGBUILD
downloadaur-06c8219c46b736ca825f60c25e11ae1fe3fa5cc9.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2f04c80f13ff
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: revel <revelΘmuub·net>
+# Contributor: Stephen Caraher <moskvax@gmail.com>
+# Contributor: Uli Armbruster <uli_armbrusterΘweb·de>
+# Contributor: Robert Gregor <gimpΘpop·de>
+
+pkgname=libvorbis-aotuv
+pkgver=b6.03
+pkgrel=5
+_releasedate=20110424-20140429
+_srcrel=2014
+pkgdesc='A fork of libvorbis intended to provide better quality sound at low to medium bitrates.'
+arch=('i686' 'x86_64')
+url='http://www.geocities.jp/aoyoume/aotuv'
+license=('BSD')
+depends=('libogg')
+conflicts=('libvorbis')
+provides=('libvorbis=1.3.4' 'libvorbisfile.so' 'libvorbis.so' 'libvorbisenc.so')
+source=("http://www.geocities.jp/aoyoume/aotuv/source_code/${pkgname}_${pkgver}_${_srcrel}.tar.bz2")
+md5sums=('2645f282bf98720dfa972993559c2925')
+sha256sums=('5c11bd73e947ab862818fe80db0ab5eaefdd4ac670bf185dd8e7a7c6ad76f2ad')
+
+prepare() {
+ cd "aotuv-${pkgver}_${_releasedate}"
+ chmod +x configure
+}
+
+build() {
+ cd "aotuv-${pkgver}_${_releasedate}"
+ ./configure --prefix=/usr --disable-static
+ make
+}
+
+check() {
+ cd "aotuv-${pkgver}_${_releasedate}"
+ make -j1 check
+}
+
+package() {
+ cd "aotuv-${pkgver}_${_releasedate}"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}