summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2018-12-05 13:22:28 +0000
committerDaniel Bermond2018-12-05 13:22:28 +0000
commit6d83e4322fba4c383da9951720d75860ae44dba4 (patch)
tree0320ee48e94f1bc84d8f05c319e285e3af91a5a3 /PKGBUILD
parent6856c9ed81c3a9a718769e242bf440f244df0db8 (diff)
downloadaur-6d83e4322fba4c383da9951720d75860ae44dba4.tar.gz
Use https for url. Do not rename the source clone.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ddd319e8d4ac..281263a62b94 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,29 +5,30 @@
# Contributor: julroy67 <gmail.com: julroy67>
pkgname=libvpx-git
-pkgver=1.7.0.r1254.ga4e70f1808
+_srcname=libvpx
+pkgver=1.7.0.r1445.g5039d2d82b
pkgrel=1
pkgdesc='VP8 and VP9 video codecs (git version)'
arch=('i686' 'x86_64')
-url='http://www.webmproject.org/'
+url='https://www.webmproject.org/'
license=('BSD')
depends=('gcc-libs')
makedepends=('git' 'yasm')
provides=('libvpx' 'libvpx.so')
conflicts=('libvpx')
-source=("$pkgname"::'git+https://chromium.googlesource.com/webm/libvpx') # official repo
-#source=("$pkgname"::'git+https://github.com/webmproject/libvpx.git') # mirror
+source=('git+https://chromium.googlesource.com/webm/libvpx') # official repo
+#source=('git+https://github.com/webmproject/libvpx.git') # mirror
sha256sums=('SKIP')
pkgver() {
- cd "$pkgname"
+ cd "$_srcname"
# git, tags available
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
}
build() {
- cd "${pkgname}"
+ cd "$_srcname"
./configure \
--prefix='/usr' \
@@ -46,7 +47,7 @@ build() {
}
package() {
- cd "${pkgname}"
+ cd "$_srcname"
make DESTDIR="$pkgdir" install