summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHurricanePootis2021-02-26 12:57:42 -0600
committerHurricanePootis2021-02-26 12:57:42 -0600
commitafb4c5b0792091b3ea8d585354b8b1ac6334412e (patch)
treea446b02244bf8fa6617a5e228ea1f049274bfee4 /PKGBUILD
downloadaur-afb4c5b0792091b3ea8d585354b8b1ac6334412e.tar.gz
Initial Commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2b3394da1f2d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: HurricanePootis <hurricanepootis@protonmail.com>
+pkgname=libvtflib-git
+pkgver=1.0.0
+pkgrel=2
+pkgdesc="Library to handle Valve's Texture Format"
+arch=('any')
+url="https://github.com/Silverlan/VTFLib"
+license=('GPL')
+depends=('libtxc_dxtn')
+makedepends=('cmake')
+source=("git+https://github.com/panzi/VTFLib.git")
+md5sums=('SKIP')
+
+
+build() {
+ cd VTFLib
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX="/usr"
+ make -j`nproc`
+}
+
+package() {
+ cd "$srcdir/VTFLib"
+ make install DESTDIR="$pkgdir"
+}