summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBrian Bidulock2014-07-10 23:53:17 -0600
committerBrian Bidulock2015-06-10 06:48:19 -0600
commit065885a22213ea7d4ac876e54c1a94515b087462 (patch)
treeafd4ab0fc3f7844acd155cf989e605a393eea7ec /PKGBUILD
parentb77397e832b8130c6cf982d6cce908f462a7fab9 (diff)
downloadaur-065885a22213ea7d4ac876e54c1a94515b087462.tar.gz
version 2.31.0.r17.gc9f5dda-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 74158728eb03..2056dccf5ec4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Jan de Groot <jgc@archlinux.org>
pkgname=libwnck+-git
pkgver=2.31.0.r17.gc9f5dda
-pkgrel=1
+pkgrel=2
pkgdesc="Window Navigator Construction Kit"
arch=('i686' 'x86_64')
license=('LGPL')
@@ -23,11 +23,14 @@ build() {
cd $pkgname
./autogen.sh --prefix=/usr --sysconfdir=/etc \
--localstatedir=/var --disable-static \
- --disable-tools
+ --enable-tools
make
}
package() {
cd $pkgname
make DESTDIR="$pkgdir" install
+ # libwnck3 installs these with the normal names linked against wrong library
+ mv "${pkgdir}"/usr/bin/wnckprop "${pkgdir}"/usr/bin/wnckprop2
+ mv "${pkgdir}"/usr/bin/wnck-urgency-monitor "${pkgdir}"/usr/bin/wnck-urgency-monitor2
}