summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChocobo12019-05-16 20:32:05 +0800
committerChocobo12019-05-16 20:35:33 +0800
commitd2a7493ba055b0dca2af3a54cc6253dcc1eeae4b (patch)
tree0bb046bcb947b1a33a07f9a904e206642a5d3f66 /PKGBUILD
downloadaur-d2a7493ba055b0dca2af3a54cc6253dcc1eeae4b.tar.gz
newpkg: libx11-git 1.6.7.r35.g99a2cf1a-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0cce4733a424
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=libx11-git
+pkgver=1.6.7.r35.g99a2cf1a
+pkgrel=1
+pkgdesc="Core X11 protocol client library"
+arch=('i686' 'x86_64')
+url="https://www.x.org/wiki/"
+license=('custom')
+depends=('glibc' 'libxcb' 'kbproto' 'xproto')
+makedepends=('git' 'inputproto' 'xextproto' 'xorg-util-macros' 'xtrans')
+provides=('libx11')
+conflicts=('libx11')
+options=('staticlibs')
+source=("git+https://gitlab.freedesktop.org/xorg/lib/libx11.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "libx11"
+
+ git describe --long --tags | sed 's/^libX11-//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "libx11"
+
+ NOCONFIGURE=1 ./autogen.sh
+ ./configure \
+ --prefix="/usr" \
+ --disable-xf86bigfont
+ make
+}
+
+check() {
+ cd "libx11"
+
+ make check
+}
+
+package() {
+ cd "libx11"
+
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "COPYING" -t "$pkgdir/usr/share/licenses/libx11"
+}