summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFantix King2015-11-17 12:42:30 +0800
committerFantix King2015-11-17 12:42:30 +0800
commit82d85b1c69839ea55c6872bca97daaac10c8cfc8 (patch)
tree2b121e2a66475e13e5f05d089fb2eb684d2bd2a8 /PKGBUILD
parent1eb243a2e58393e0deec165ccd95b9797be27518 (diff)
downloadaur-82d85b1c69839ea55c6872bca97daaac10c8cfc8.tar.gz
2.46.1-1.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 62d4aa474854..6f1a168ee86f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 122984 2014-11-23 10:25:53Z bluewind $
+# $Id: PKGBUILD 144547 2015-10-21 05:26:35Z fyan $
# Maintainer: Ionut Biru <ibiru@archlinux.org>
# Contributor: Pierre Schmitz <pierre@archlinux.de>
# Contributor: Mikko Seppälä <t-r-a-y@mbnet.fi>
@@ -6,7 +6,7 @@
_pkgbasename=glib2
pkgname=libx32-$_pkgbasename
-pkgver=2.42.1
+pkgver=2.46.1
pkgrel=1.1
pkgdesc="Common C routines used by GTK+ 2.4 and other libs (x32 ABI)"
url="http://www.gtk.org/"
@@ -17,7 +17,7 @@ makedepends=('gcc-multilib-x32' 'python2')
options=('!docs')
source=("http://ftp.gnome.org/pub/GNOME/sources/glib/${pkgver%.*}/glib-${pkgver}.tar.xz"
'revert-warn-glib-compile-schemas.patch')
-sha256sums=('8f3f0865280e45b8ce840e176ef83bcfd511148918cc8d39df2ee89b67dcf89a'
+sha256sums=('5a1f03b952ebc3a7e9f612b8724f70898183e31503db329b4f15d07163c8fdfb'
'049240975cd2f1c88fbe7deb28af14d4ec7d2640495f7ca8980d873bb710cc97')
prepare() {
@@ -30,6 +30,11 @@ build() {
export CXX="g++ -mx32"
export PKG_CONFIG_PATH="/usr/libx32/pkgconfig"
+ ## Prevent runtime unloading of glib
+ # https://bugs.archlinux.org/task/46619
+ # https://bugzilla.gnome.org/show_bug.cgi?id=755609
+ LDFLAGS+=" -Wl,-z,nodelete"
+
cd "${srcdir}/glib-${pkgver}"
PYTHON=/usr/bin/python2 ./configure --prefix=/usr --sysconfdir=/etc \
--libdir=/usr/libx32 --with-pcre=system --disable-fam