summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFantix King2014-05-20 18:40:10 +0800
committerFantix King2015-11-13 01:19:09 +0800
commit99395b9de3eed0772fcb5f1e00c08d67a5c78402 (patch)
tree10eb29796c1d89974d5eecba87152b9e047dbb21 /PKGBUILD
parent867ac9c311539b29231f07a912926dc11580c47f (diff)
downloadaur-99395b9de3eed0772fcb5f1e00c08d67a5c78402.tar.gz
2.19_5-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 17 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2386922ed438..a40c6d0add07 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 110036 2014-04-23 14:15:04Z heftig $
+# $Id: PKGBUILD 111334 2014-05-16 22:03:28Z heftig $
# Maintainer: Fantix King <fantix.king@gmail.com>
# Upstream Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
# Contributor: Jan de Groot <jgc@archlinux.org>
@@ -9,24 +9,29 @@
_pkgbasename=glibc
pkgname=libx32-$_pkgbasename
-pkgver=2.19_4
+pkgver=2.19_5
pkgrel=1
-pkgdesc="GNU C Library for x32 ABI"
+pkgdesc="GNU C Library (x32 ABI)"
arch=('x86_64')
url="http://www.gnu.org/software/libc"
license=('GPL' 'LGPL')
-makedepends=('gcc-multilib-x32>=4.7')
+groups=()
+depends=()
+makedepends=('gcc-multilib-x32>=4.8')
+backup=()
conflicts=('glibc-x32-seed')
provides=('glibc-x32-seed')
options=('!strip' '!emptydirs' 'staticlibs')
source=(http://ftp.gnu.org/gnu/libc/${_pkgbasename}-${pkgver%_*}.tar.xz{,.sig}
glibc-2.19-xattr_header.patch
glibc-2.19-fix-sign-in-bsloww1-input.patch
+ glibc-2.19-tzselect-default.patch
libx32-glibc.conf)
md5sums=('e26b8cc666b162f999404b03970f14e4'
'SKIP'
'39a4876837789e07746f1d84cd8cb46a'
'755a1a9d7844a5e338eddaa9a5d974cd'
+ 'c772dc99ddd8032ecbf43884ae0cf42e'
'34a4169d2bdc5a3eb83676a0831aae57')
prepare() {
@@ -38,6 +43,9 @@ prepare() {
# fix issues in sin/cos slow path calculation - commit ffe768a9
patch -p1 -i $srcdir/glibc-2.19-fix-sign-in-bsloww1-input.patch
+ # fix tzselect with missing TZDIR - commit 893b4f37/c72399fb
+ patch -p1 -i $srcdir/glibc-2.19-tzselect-default.patch
+
mkdir ${srcdir}/glibc-build
}
@@ -65,7 +73,7 @@ build() {
echo "rootsbindir=/usr/bin" >> configparms
# remove hardening options for building libraries
- CFLAGS=${CFLAGS/-fstack-protector/}
+ CFLAGS=${CFLAGS/-fstack-protector-strong/}
CPPFLAGS=${CPPFLAGS/-D_FORTIFY_SOURCE=2/}
${srcdir}/${_pkgbasename}-${pkgver%_*}/configure --prefix=/usr \
@@ -87,8 +95,8 @@ build() {
# re-enable hardening for programs
sed -i "/build-programs=/s#no#yes#" configparms
- echo "CC += -fstack-protector -D_FORTIFY_SOURCE=2" >> configparms
- echo "CXX += -fstack-protector -D_FORTIFY_SOURCE=2" >> configparms
+ echo "CC += -fstack-protector-strong -D_FORTIFY_SOURCE=2" >> configparms
+ echo "CXX += -fstack-protector-strong -D_FORTIFY_SOURCE=2" >> configparms
make
# remove harding in preparation to run test-suite
@@ -103,8 +111,8 @@ check() {
if [ -x "/opt/gcc-x32-seed/bin/gcc" ]; then
make -k check || true
else
- # only acceptable testsuite error is some small libm ulp failures on i686 with gcc-4.9
- # TODO: fix upstream and provide patch
+ # ULP failures on i686 are all small and can be ignored
+ # tst-cleanupx4.out failure on i686 needs investigating...
make -k check || true
fi
}