summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFantix King2012-09-22 16:23:20 +0800
committerFantix King2015-12-30 08:43:49 +0800
commit5b72230fd2a0d5e7163f7512aad4ef40697b5eeb (patch)
tree88ffa6b12263095c8d217f9edf9152a47f25292e /PKGBUILD
downloadaur-5b72230fd2a0d5e7163f7512aad4ef40697b5eeb.tar.gz
2.4.32-1.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD61
1 files changed, 61 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..34106cdbda7a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# $Id: PKGBUILD 74901 2012-08-09 08:07:41Z bluewind $
+# Maintainer:
+# Contributor: Judd Vinet <jvinet@zeroflux.org>
+
+_pkgbasename=libldap
+pkgname=libx32-$_pkgbasename
+pkgver=2.4.32
+pkgrel=1.1
+pkgdesc="Lightweight Directory Access Protocol (LDAP) client libraries (x32 ABI)"
+arch=('x86_64')
+license=('custom')
+url="http://www.openldap.org/"
+depends=('libx32-openssl' $_pkgbasename)
+makedepends=(gcc-multilib)
+options=('!libtool')
+source=("ftp://ftp.openldap.org/pub/OpenLDAP/openldap-release/openldap-${pkgver}.tgz"
+ 'ntlm.patch')
+md5sums=('6a3e85cf61860ca5e8a1eba6753dd9d0'
+ '4258ddbef923d1f29f2843bc050f8c56')
+
+build() {
+ export CC="gcc -mx32"
+ export CXX="g++ -mx32"
+ export PKG_CONFIG_PATH="/usr/libx32/pkgconfig"
+
+ cd ${srcdir}/openldap-${pkgver}
+
+ patch -Np1 -i ${srcdir}/ntlm.patch
+
+ ./configure --prefix=/usr \
+ --libexecdir=/usr/sbin \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var/lib/openldap \
+ --enable-crypt --enable-dynamic \
+ --with-threads --disable-wrappers \
+ --disable-spasswd --without-cyrus-sasl \
+ --disable-bdb --disable-hdb --libdir=/usr/libx32
+
+ cd include
+ make
+
+ cd ../libraries
+ make depend
+ make
+
+}
+
+package() {
+ cd ${srcdir}/openldap-${pkgver}
+
+ cd include
+ make DESTDIR=${pkgdir} install
+
+ cd ../libraries
+ make DESTDIR=${pkgdir} install
+
+ rm -rf "${pkgdir}"/usr/{include,share,bin} "$pkgdir/etc"
+ mkdir -p "$pkgdir/usr/share/licenses"
+ ln -s $_pkgbasename "$pkgdir/usr/share/licenses/$pkgname"
+}