summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChocobo12019-05-16 20:52:40 +0800
committerChocobo12019-05-16 20:52:40 +0800
commit5ad0030ced82dd98b49d30ae87c5eff3cbb7f336 (patch)
treeb7cbf8c594938d9856bca3da9a6d6bf77820422c /PKGBUILD
downloadaur-5ad0030ced82dd98b49d30ae87c5eff3cbb7f336.tar.gz
newpkg: libxext-git 1.3.4.r0.gebb167f-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fe6e4c251319
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=libxext-git
+pkgver=1.3.4.r0.gebb167f
+pkgrel=1
+pkgdesc="X11 common extensions library"
+arch=('i686' 'x86_64')
+url="https://www.x.org/wiki/"
+license=('custom')
+depends=('glibc' 'libx11' 'xextproto')
+makedepends=('git' 'xorg-util-macros')
+provides=('libxext')
+conflicts=('libxext')
+options=('staticlibs')
+source=("git+https://gitlab.freedesktop.org/xorg/lib/libxext.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "libxext"
+
+ git describe --long --tags | sed 's/^libXext-//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "libxext"
+
+ NOCONFIGURE=1 ./autogen.sh
+ ./configure \
+ --prefix="/usr"
+ make
+}
+
+check() {
+ cd "libxext"
+
+ make check
+}
+
+package() {
+ cd "libxext"
+
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "COPYING" -t "$pkgdir/usr/share/licenses/libxext"
+}