summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSantiago Lo Coco2022-01-10 23:22:47 -0300
committerSantiago Lo Coco2022-01-10 23:22:47 -0300
commit8ee7d883bd048de80e9909f79d4452575ff9ecc5 (patch)
tree3cad7cf0d3c2659b978c206f4c1550bfd51e3370 /PKGBUILD
parente7f30d5dcba8e7e040e4a024bf3ac5e22decf891 (diff)
downloadaur-8ee7d883bd048de80e9909f79d4452575ff9ecc5.tar.gz
Update PKGBUILD and .SRCINFO
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 15 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dc4a2230c8c6..def6f6cd789a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,30 @@
-_pkgbasever=2.3.3
+# Maintainer: Santiago Lo Coco <santilococo.01@gmail.com>
+
pkgname=libxft-bgra
-pkgver=2.3.3.r7.7808631e
+pkgver=2.3.4
pkgrel=1
-pkgdesc="libXft with BGRA glyph (color emoji) rendering & scaling patches by Maxime Coste"
+pkgdesc="X FreeType library with support for BGRA glyphs and scaling"
arch=('x86_64')
+url="https://xorg.freedesktop.org"
license=('custom')
-groups=('modified')
provides=('libxft')
conflicts=('libxft')
-url="https://gitlab.freedesktop.org/xorg/lib/libxft.git"
-depends=('fontconfig' 'libxrender' 'curl' 'xorg-util-macros')
-makedepends=('git' 'pkgconf')
-source=("git+$url" "https://gitlab.freedesktop.org/xorg/lib/libxft/merge_requests/1.patch")
-md5sums=('SKIP' 'SKIP')
-
+depends=('fontconfig' 'libxrender')
+makedepends=('pkgconf')
+source=("${url}/releases/individual/lib/libXft-${pkgver}.tar.bz2"
+ "bgra_patch::https://gitlab.freedesktop.org/xorg/lib/libxft/merge_requests/1.patch")
+sha256sums=('57dedaab20914002146bdae0cb0c769ba3f75214c4c91bd2613d6ef79fc9abdd'
+ '0e313ab2eccd7d2f68fc2d409493dd972de9cbe70510c4eb707ad16f8ed6f03e')
build() {
- cd libxft
- patch -p1 < ../1.patch
- sh autogen.sh --sysconfdir=/etc --prefix=/usr --mandir=/usr/share/man
+ cd "${srcdir}/libXft-${pkgver}"
+ patch -p1 < "${srcdir}/bgra_patch"
+ sh configure --prefix=/usr --sysconfdir=/etc --disable-static
make
}
package() {
- cd libxft
+ cd "${srcdir}/libXft-${pkgver}"
make DESTDIR="${pkgdir}" install
install -d -m755 "${pkgdir}/usr/share/licenses/${pkgname}"
install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/"