summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMiroslav Koškár2019-10-25 21:37:32 +0200
committerMiroslav Koškár2019-10-25 21:37:32 +0200
commit52ba6bf58add104f6437e4ba8ac83bd7665057a5 (patch)
tree0510b0343f58fba4f3829d059d4abeccbf9ccdf8 /PKGBUILD
downloadaur-52ba6bf58add104f6437e4ba8ac83bd7665057a5.tar.gz
Initial
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d27e1fa9d9b5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Miroslav Koškár <http://mkoskar.com/>
+
+_basename=libxinerama-randr
+
+pkgname=libxinerama-randr-git
+pkgver=1.1.4.r3.g55d1524
+pkgrel=1
+pkgdesc='Fork of libXinerama using RANDR for it to work in Zaphod mode'
+url='https://github.com/mkoskar/libxinerama-randr'
+license=(custom)
+arch=(x86_64)
+
+depends=(libxext xineramaproto 'libxrandr>=1.5')
+provides=(libxinerama)
+conflicts=(libxinerama)
+makedepends=(xorg-util-macros)
+
+source=("git+https://github.com/mkoskar/$_basename.git")
+sha256sums=(SKIP)
+
+pkgver() {
+ cd "$_basename"
+ git describe --long --tags | sed 's/libXinerama-//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$_basename"
+ ./autogen.sh --prefix=/usr
+ make
+}
+
+package() {
+ cd "$_basename"
+ make DESTDIR="$pkgdir" install
+ install -D -m644 -t "$pkgdir/usr/share/licenses/$_basename" COPYING
+}