summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChocobo12017-08-20 13:34:54 +0800
committerChocobo12017-08-20 13:51:33 +0800
commitb4fb7686b5386a228a2183ed7ac0c313271f9b70 (patch)
tree403257fab207ffa66eefda71937535c698c052ba /PKGBUILD
downloadaur-b4fb7686b5386a228a2183ed7ac0c313271f9b70.tar.gz
newpkg: libxml2-git 2.9.4.r99.g27f310d4-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..54597678b438
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=libxml2-git
+pkgver=2.9.4.r99.g27f310d4
+pkgrel=1
+pkgdesc="The XML C parser and toolkit of Gnome"
+arch=('i686' 'x86_64')
+url="https://libxml2.freedesktop.org/wiki/"
+license=('MIT')
+depends=('glibc' 'icu' 'xz' 'zlib' 'sh')
+makedepends=('git')
+provides=('libxml2')
+conflicts=('libxml2')
+options=('staticlibs')
+source=("git+https://git.gnome.org/browse/libxml2")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "libxml2"
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "libxml2"
+
+ NOCONFIGURE=1 ./autogen.sh
+ ./configure --prefix="/usr" --with-history --with-icu
+ make
+}
+
+check() {
+ cd "libxml2"
+
+ make check
+}
+
+package() {
+ cd "libxml2"
+
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "Copyright" "$pkgdir/usr/share/licenses/libxml2/Copyright"
+}