summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChocobo12017-11-12 06:26:58 +0800
committerChocobo12017-11-12 06:30:32 +0800
commitd2cf508548923b61d192e2e7f133b84fef65a2db (patch)
tree4d6cf78ad83a94dde60af5d488bfa1797b13d400 /PKGBUILD
downloadaur-d2cf508548923b61d192e2e7f133b84fef65a2db.tar.gz
newpkg: libyaml-git 0.1.7.r44.g660242d-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ccfd8858069b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=libyaml-git
+pkgver=0.1.7.r44.g660242d
+pkgrel=1
+pkgdesc="Provides useful functions commonly found on BSD systems"
+arch=('i686' 'x86_64')
+url="https://pyyaml.org/wiki/LibYAML"
+license=('MIT')
+depends=('glibc')
+makedepends=('git')
+provides=('libyaml')
+conflicts=('libyaml')
+options=('staticlibs')
+source=("git+https://github.com/yaml/libyaml.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "libyaml"
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "libyaml"
+
+ ./bootstrap
+ ./configure --prefix="/usr"
+ make
+}
+
+check() {
+ cd "libyaml"
+
+ make check
+}
+
+package() {
+ cd "libyaml"
+
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/libyaml/LICENSE"
+}