summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMoritz Lipp2020-03-27 19:02:09 +0100
committerMoritz Lipp2020-03-27 19:02:09 +0100
commitd42d687873a5465821cd328d722c0d6fc6c6bffd (patch)
tree6ae444434d39fd839da402f8ef86cac55b222ea9 /PKGBUILD
parent374e1ff173d7b1693d001f53a967bdaea350786e (diff)
downloadaur-d42d687873a5465821cd328d722c0d6fc6c6bffd.tar.gz
Update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 15 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 100b0d519c30..9b6a3362963d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,38 +3,43 @@
_pkgname=libzathura
pkgname=libzathura-git
-pkgver=f0fe052
+pkgver=69efc7d
pkgrel=1
pkgdesc="A document library."
arch=('i686' 'x86_64')
url="http://pwmt.org/projects/libzathura"
license=('custom')
depends=('glib2>=2.28' 'intltool' 'file')
-makedepends=('git')
+makedepends=('git' 'python-sphinx' 'intltool' 'meson')
checkdepends=('check' 'libfiu')
conflicts=('libzathura')
provides=('libzathura')
source=("${_pkgname}::git+https://git.pwmt.org/pwmt/libzathura.git#branch=develop")
md5sums=('SKIP')
+_gitname=libzathura
+
+prepare() {
+ mkdir -p build
+}
build() {
- cd "$srcdir/$_pkgname"
- make
+ cd build
+ meson --prefix=/usr --buildtype=release $srcdir/$_gitname
+ ninja
}
check() {
- cd "$srcdir/$_pkgname"
- make test || return 0
+ cd build
+ ninja test
}
package() {
- cd "$srcdir/$_pkgname"
- make DESTDIR="$pkgdir/" install
- install -D -m664 LICENSE "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+ cd build
+ DESTDIR="$pkgdir/" ninja install
}
pkgver() {
- cd "$_pkgname"
+ cd "$_gitname"
git describe --long --always | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
}