summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjusticehunter2020-08-20 14:46:10 +0200
committerjusticehunter2020-08-20 14:46:10 +0200
commit6ea7a0b5510ddeb1d90420c159b12ed4df3398e7 (patch)
tree97b9f1bd6b8d46f78f5a6273d9de703913137f52 /PKGBUILD
parent04855e9206cdce28af79377b22cf07f1978f0c8e (diff)
downloadaur-libzrtpcpp.tar.gz
build and install commands made generic to be compatible with make, ninja etc.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 2 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4554ee9b1c34..1744d96d765e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -28,10 +28,9 @@ build() {
cmake ../ZRTPCPP-${pkgver} \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release
- make
+ cmake --build .
}
package() {
- cd build
- make DESTDIR="${pkgdir}" install
+ cmake --install build --prefix "${pkgdir}"/usr
}