summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGeorge Rawlinson2020-03-20 18:31:20 +1300
committerGeorge Rawlinson2020-03-20 18:31:20 +1300
commit88465371204d1c4597ac924691283eb5a526dfa7 (patch)
tree9a1e61a3ce5ab0a4682b2adb955d737b4b08c7f1 /PKGBUILD
parenteaeac0ef8790a7ab0a9b1ad5b79063c4dd20efce (diff)
downloadaur-88465371204d1c4597ac924691283eb5a526dfa7.tar.gz
upgpkg: license-detector 3.1.0-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4c64a0a13967..d23526d69712 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,26 +3,26 @@
pkgname=license-detector
_pkgname="go-$pkgname"
pkgver=3.1.0
-pkgrel=1
+pkgrel=2
pkgdesc="Reliable project licenses detector"
arch=('x86_64')
url="https://github.com/src-d/go-license-detector"
license=('Apache')
-makedepends=('go-pie')
+makedepends=('go')
source=("$pkgname-$pkgver.tar.gz::https://github.com/src-d/go-license-detector/archive/v3.1.0.tar.gz")
sha256sums=('bb12da726fa39e62f8547c86db13a919ad7f0bdf229be158e68e8aff382b6575')
prepare() {
cd "$_pkgname-$pkgver"
- go mod download
+ go mod vendor
}
build() {
+ export CGO_LDFLAGS="$LDFLAGS"
+ export GOFLAGS="-buildmode=pie -trimpath -mod=vendor -modcacherw"
cd "$_pkgname-$pkgver"
go build \
- -trimpath \
- -ldflags "-extldflags $LDFLAGS" \
- -v gopkg.in/src-d/go-license-detector.v3/cmd/license-detector
+ gopkg.in/src-d/go-license-detector.v3/cmd/license-detector
}
package() {