summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authortxtsd2024-10-26 18:22:13 +0530
committertxtsd2024-10-26 18:25:46 +0530
commitf99b60000f8aa85e58c88e7050dbf03fdbe93fdb (patch)
treef8d42223cd9adc2e0b1ba9cd9bca25da8c7d467e /PKGBUILD
parent5759ace5e18c8248f03f6fb66df1ea51091417a8 (diff)
downloadaur-f99b60000f8aa85e58c88e7050dbf03fdbe93fdb.tar.gz
upgpkg: lidarr-develop 2.7.1.4417-2
Move restore to prepare() Remove extraneous dotnet output Remove additional components Remove unnecessary tests link Use system fpcalc Use correct branch Add more optdepends Add comments Signed-off-by: txtsd <code@ihavea.quest>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 25 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1c76e2eb099e..1cc70e7f26ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=lidarr-develop
_pkgname=Lidarr
pkgver=2.7.1.4417
-pkgrel=1
+pkgrel=2
pkgdesc='Music collection manager for newsgroup and torrent users (develop branch)'
arch=('x86_64' 'aarch64' 'armv7h')
url='https://lidarr.audio'
@@ -26,6 +26,9 @@ optdepends=(
'qbittorrent: torrent downloader'
'deluge: torrent downloader'
'rtorrent: torrent downloader'
+ 'nodejs-flood: torrent downloader'
+ 'vuze: torrent downloader'
+ 'aria2: torrent downloader'
'transmission-cli: torrent downloader (CLI and daemon)'
'transmission-gtk: torrent downloader (GTK+)'
'transmission-qt: torrent downloader (Qt)'
@@ -60,41 +63,49 @@ _framework='net6.0'
_runtime="linux-${_CARCH}"
_output="_output"
_artifacts="${_output}/${_framework}/${_runtime}/publish"
+_branch='master'
prepare() {
cd "${srcdir}/${_pkgname}-${pkgver}"
- # Fix CVE-2024-43485
- sed 's/System\.Text\.Json" Version="6\.0\.9"/System\.Text\.Json" Version="6\.0\.10"/' -i src/NzbDrone.Common/Lidarr.Common.csproj
- sed 's/System\.Text\.Json" Version="6\.0\.9"/System\.Text\.Json" Version="6\.0\.10"/' -i src/NzbDrone.Core/Lidarr.Core.csproj
+ # Prepare backend
+ export DOTNET_CLI_TELEMETRY_OPTOUT=1
+ export DOTNET_NOLOGO=1
+ export DOTNET_SKIP_FIRST_TIME_EXPERIENCE=1
+ dotnet restore src/${_pkgname}.sln \
+ --runtime ${_runtime} \
+ --locked-mode
+ # Prepare frontend
yarn install --frozen-lockfile --network-timeout 120000
}
build() {
cd "${srcdir}/${_pkgname}-${pkgver}"
+ # Build backend
export DOTNET_CLI_TELEMETRY_OPTOUT=1
+ export DOTNET_NOLOGO=1
+ export DOTNET_SKIP_FIRST_TIME_EXPERIENCE=1
dotnet build src/${_pkgname}.sln \
--framework ${_framework} \
--runtime ${_runtime} \
--no-self-contained \
+ --no-restore \
--configuration Release \
-p:Platform=Posix \
-p:AssemblyVersion=${pkgver} \
- -p:AssemblyConfiguration=main \
+ -p:AssemblyConfiguration=${_branch} \
-p:RuntimeIdentifiers=${_runtime} \
-t:PublishAllRids \
- && dotnet build-server shutdown # Build servers do not terminate automatically
- # Remove Service Helpers, Update, and Windows files
+ # Remove fpcalc, Service Helpers, Update, and Windows files
+ rm "${_artifacts}/fpcalc"
rm "${_artifacts}/ServiceInstall."*
rm "${_artifacts}/ServiceUninstall."*
rm "${_artifacts}/Lidarr.Windows."*
- # Use fpcalc from chromaprint package
- rm -f "${_artifacts}/fpcalc"
-
+ # Build frontend
yarn run build --env production
}
@@ -109,10 +120,10 @@ check() {
_filters="${_filters}&FullyQualifiedName!~should_get_version_info_from_actual_linux"
_filters="${_filters}&Category!=IntegrationTest"
- # Link build to tests
- ln -sf ../../${_artifacts} _tests/${_framework}/${_runtime}/bin
+ # Prepare for tests
mkdir -p ~/.config/Lidarr
+ # Test backend
dotnet test src \
--runtime "${_runtime}" \
--configuration Release \
@@ -124,7 +135,9 @@ package() {
cd "${srcdir}/${_pkgname}-${pkgver}"
install -dm755 "${pkgdir}/usr/lib/lidarr/bin/UI"
+ # Copy backend
cp -dpr --no-preserve=ownership "${_artifacts}/"* "${pkgdir}/usr/lib/lidarr/bin"
+ # Copy frontend
cp -dpr --no-preserve=ownership "${_output}/UI/"* "${pkgdir}/usr/lib/lidarr/bin/UI"
# License