summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authornephitejnf2020-07-27 16:05:46 -0600
committernephitejnf2020-07-27 16:05:46 -0600
commit6ed9aff3aee74e541dcb7ef329ba8cf2b19ed950 (patch)
treec62bbf72339a7e6c454bf40cca4f6653b63d4dde /PKGBUILD
parentdd11bb9c4f2d115ce159b895ff782208f7575172 (diff)
downloadaur-6ed9aff3aee74e541dcb7ef329ba8cf2b19ed950.tar.gz
Desktop entry and icon, other small improvements
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 18 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 062a9ffe328b..b2cf51e317f1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,35 @@
# Maintainer: nephitejnf <nephitejnf@gmail.com>
pkgname=lightcord-bin
pkgver=v0.1.3
-pkgrel=1
+pkgrel=2
pkgdesc="A simple - customizable - Discord Client"
arch=("x86_64")
url="https://github.com/Lightcord/Lightcord"
+provides=('discord')
license=('MIT')
depends=()
makedepends=()
-source=("$pkgname-$pkgver.zip::https://lightcord.deroku.xyz/api/v1/gh/releases/Lightcord/Lightcord/$pkgver/lightcord-linux-x64.zip")
-md5sums=("SKIP")
+source=("$pkgname-$pkgver.zip::https://lightcord.deroku.xyz/api/v1/gh/releases/Lightcord/Lightcord/$pkgver/lightcord-linux-x64.zip"
+ "Lightcord.desktop"
+ "https://raw.githubusercontent.com/Lightcord/LightcordLogos/master/lightcord/lightcord.png")
+md5sums=("d24b1af29cc18ede4713e3cb372cff15"
+ "7f7ade1f48d8aa92809463ba40663936"
+ "f1ace6f149a3d778bfb789d10181d877")
package() {
+ # Create the folder structure
install -d "$pkgdir"/usr/share/lightcord
install -d "$pkgdir"/usr/bin
+ install -d "$pkgdir"/usr/share/pixmaps
+
+ # Copy files over and set rights
cp -a "$srcdir"/. "$pkgdir"/usr/share/lightcord
chmod 755 "$pkgdir"/usr/share/lightcord/Lightcord
+
+ # Link icon and add Desktop
+ ln -s /usr/share/lightcord/lightcord.png "$pkgdir"/usr/share/pixmaps/lightcord.png
+ install -Dm644 "$pkgdir"/usr/share/lightcord/Lightcord.desktop -t "$pkgdir"/usr/share/applications
+
+ # Create symlink in /usr/bin; stolen from other PKGBUILDs
ln -s /usr/share/lightcord/Lightcord "$pkgdir"/usr/bin/lightcord
}