summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAleksandar Trifunovic2018-06-16 16:56:53 +0200
committerAleksandar Trifunovic2018-06-16 16:56:53 +0200
commit21acfd1a836a3cfc4b2c658db5d88058c72ddc92 (patch)
treefda29e92f19fc4796ab849d6437372f0b0e6d5b6 /PKGBUILD
downloadaur-21acfd1a836a3cfc4b2c658db5d88058c72ddc92.tar.gz
v2.1.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..671e9a8f254c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Aleksandar Trifunović <akstrfn at gmail dot com>
+
+_pkgname=LightGBM
+pkgname=lightgbm
+pkgver=2.1.1
+pkgrel=1
+pkgdesc="Distributed gradient boosting framework based on decision tree algorithms."
+arch=('x86_64')
+url="https://github.com/Microsoft/LightGBM"
+license=('MIT')
+depends=('boost-libs' 'ocl-icd')
+makedepends=('boost' 'cmake' 'opencl-headers')
+source=("https://github.com/Microsoft/LightGBM/archive/v${pkgver}.tar.gz")
+sha256sums=('07da54e835f4d9991fbc526b4e0c9d0d2a47e514c6eb94de2fbb49c33c8a1e6e')
+
+build() {
+ cd "${_pkgname}-${pkgver}"
+ cmake -H. -Bbuild \
+ -DCMAKE_C_FLAGS:STRING="${CFLAGS}" \
+ -DCMAKE_CXX_FLAGS:STRING="${CXXFLAGS}" \
+ -DCMAKE_EXE_LINKER_FLAGS:STRING="${LDFLAGS}" \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DUSE_OPENMP=ON \
+ -DUSE_GPU=ON \
+
+ cmake --build build
+}
+
+package() {
+ cd "${_pkgname}-${pkgver}"
+ cmake --build build -- DESTDIR="${pkgdir}" install
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}