summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSefa Eyeoglu2020-08-03 13:07:02 +0200
committerSefa Eyeoglu2020-08-03 13:07:02 +0200
commita309a5832aa018c8f598abbea0ec199b79a5184f (patch)
tree2183b5e11a78bc6cd5a8ee182d636037fcf5adc4 /PKGBUILD
downloadaur-a309a5832aa018c8f598abbea0ec199b79a5184f.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e78f5087ce28
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# Maintainer: Sefa Eyeoglu <contact@scrumplex.net>
+
+_pkgname=lightly
+pkgname=${_pkgname}-git
+pkgver=r2022.fe1663e1
+pkgrel=1
+pkgdesc="A modern style for qt applications, forked from Breeze"
+arch=(x86_64)
+url="https://github.com/Luwx/Lightly"
+license=("GPL2")
+depends=("frameworkintegration" "kdecoration" "breeze-icons" "kwayland" "hicolor-icon-theme")
+makedepends=("git" "extra-cmake-modules" "kcmutils")
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("${_pkgname}::git+https://github.com/Luwx/Lightly.git")
+sha512sums=('SKIP')
+
+
+pkgver() {
+ cd "$srcdir/${_pkgname}"
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cmake -B build -S "${_pkgname}" \
+ -DBUILD_TESTING=OFF
+ cmake --build build
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+}