summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlad Wenter2017-09-10 21:30:57 +0200
committerAlad Wenter2017-09-10 21:30:57 +0200
commit55d61ef4020945f8e2e4d10fa697476a3e36b41f (patch)
treefad31488db935876b3b0abf65fdee1f370788e3c /PKGBUILD
parent013ee585d0e1a64a591d2168439727e1df94c394 (diff)
downloadaur-55d61ef4020945f8e2e4d10fa697476a3e36b41f.tar.gz
lightspark-git: rm .install and respective deps
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 11 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 97a54d92cd58..fb7281636432 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,32 @@
-# Maintainer: Daniel Landau <daniel+aur@landau.fi>
+# Maintainer: Alad Wenter <alad@archlinux.info>
+# Contributor: Daniel Landau <daniel+aur@landau.fi>
# Contributor: sekret, mail=$(echo c2VrcmV0QHBvc3Rlby5zZQo= | base64 -d)
# Contributor: mmm
# Contributor: bslackr <brendan at vastactive dot com>
# Contributor: Jan "heftig" Steffens <jan.steffens@gmail.com>
# Contributor: Thomas Dziedzic < gostrc at gmail >
-_pkgname=lightspark
-pkgname=$_pkgname-git
-pkgver=0.7.2.r584.g1876a7b
+pkgname=lightspark-git
+pkgver=0.8.0.r45.g06d58822
pkgrel=1
pkgdesc="An open source flash player implementation"
arch=('i686' 'x86_64')
url="http://lightspark.sourceforge.net"
license=('LGPL3')
-depends=('gtk2' 'boost-libs' 'glew' 'ffmpeg' 'curl' 'desktop-file-utils' 'rtmpdump' 'sdl2_mixer' 'glibmm')
+depends=('gtk2' 'boost-libs' 'glew' 'ffmpeg' 'rtmpdump' 'sdl2_mixer' 'glibmm')
makedepends=('git' 'cmake' 'nasm' 'llvm' 'boost')
optdepends=('gnash-gtk: Gnash fallback support')
-provides=("$_pkgname")
-conflicts=("$_pkgname")
-install=$pkgname.install
-source=("$_pkgname::git+https://github.com/lightspark/lightspark.git")
+provides=('lightspark')
+conflicts=('lightspark')
+source=("$pkgname::git+https://github.com/lightspark/lightspark.git")
md5sums=('SKIP')
pkgver() {
- cd "$_pkgname"
+ cd "$pkgname"
git describe --long --tags | sed -r 's/^lightspark-//;s/([^-]*-g)/r\1/;s/-/./g'
}
build() {
- cd "$_pkgname"
+ cd "$pkgname"
cmake \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCOMPILE_PLUGIN=1 \
@@ -38,7 +37,7 @@ build() {
}
package() {
- cd "$_pkgname"
+ cd "$pkgname"
make DESTDIR="$pkgdir/" install
}