summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Arndt2019-11-14 05:54:38 +0100
committerChristopher Arndt2019-11-14 05:54:38 +0100
commit794ce83a7b6f78e725e0317a3c0a2cdc60e747d6 (patch)
treec5bdf99c5a7733a1a5983180a8e374c58c160eed /PKGBUILD
parent618540db775e73b81b984fb9d4f71f4ec4c1385f (diff)
downloadaur-794ce83a7b6f78e725e0317a3c0a2cdc60e747d6.tar.gz
Add 'liblilv-0.so' to provides (same as non-git package, required by other packages)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 99fd66f33fac..d1a25888e1d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgname=lilv
pkgname="${_pkgname}-git"
-pkgver=0.24.5.r1249.36e74a7
+pkgver=0.24.6.r1258.425af42
pkgrel=1
pkgdesc="A C library interface to the LV2 plug-in standard with Python bindings (git version)"
arch=('i686' 'x86_64')
@@ -16,11 +16,14 @@ optdepends=(
"bash-completion: completion for bash"
"libsndfile: lv2apply utility"
)
-provides=("${_pkgname}" "${_pkgname}=${pkgver//.r*/}")
+provides=("${_pkgname}" "${_pkgname}=${pkgver//.r*/}" "liblilv-${pkver::1}.so")
conflicts=("${_pkgname}" "${_pkgname}-svn")
source=("${_pkgname}::git+https://gitlab.com/lv2/${_pkgname}.git"
- 'autowaf::git+https://gitlab.com/drobilla/autowaf.git')
-md5sums=('SKIP' 'SKIP')
+ 'autowaf::git+https://gitlab.com/drobilla/autowaf.git'
+ 'lilv-no-empty-collection-assert.patch')
+md5sums=('SKIP'
+ 'SKIP'
+ '5d60a2514d5f81c5335d9278057bf0ae')
pkgver() {
@@ -37,9 +40,7 @@ prepare() {
git config submodule.waflib.url "${srcdir}/autowaf"
git submodule update
- # Ugly hack to fix pkgconfig file template
- # https://github.com/drobilla/lilv/issues/30
- sed -i -e 's/^Requires:.*/Requires: @LILV_PKG_DEPS@/' lilv.pc.in
+ patch -p1 -N -i "${srcdir}"/lilv-no-empty-collection-assert.patch
}
check() {