summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Arndt2019-05-16 17:12:59 +0200
committerChristopher Arndt2019-05-16 17:12:59 +0200
commita83271e348980254143b4dfae73f2a761ab0219c (patch)
tree357dbf3c8b2b46c4c842012f1d8894d352fb82e9 /PKGBUILD
parent3c4aa47ac8ee2d71289f38e0211b6267d473e91e (diff)
downloadaur-a83271e348980254143b4dfae73f2a761ab0219c.tar.gz
Upstream repository changed and now uses git submodule for waflib
Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 13 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 253f33472035..3509732a4925 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgname=lilv
pkgname="${_pkgname}-git"
-pkgver=0.24.5.r1185.bf061a4
+pkgver=0.24.5.r1218.9091b84
pkgrel=1
pkgdesc="A C library interface to the LV2 plug-in standard"
arch=('i686' 'x86_64')
@@ -18,8 +18,9 @@ optdepends=(
)
provides=("${_pkgname}" "${_pkgname}=${pkgver//.r*/}")
conflicts=("${_pkgname}" "${_pkgname}-svn")
-source=("${_pkgname}::git+http://git.drobilla.net/${_pkgname}.git")
-md5sums=('SKIP')
+source=("${_pkgname}::git+https://gitlab.com/lv2/${_pkgname}.git"
+ 'autowaf::git+https://gitlab.com/drobilla/autowaf.git')
+md5sums=('SKIP' 'SKIP')
pkgver() {
cd "${srcdir}/${_pkgname}"
@@ -28,6 +29,14 @@ pkgver() {
echo "$ver.r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd "${srcdir}/${_pkgname}"
+
+ git submodule init
+ git config submodule.waflib.url "${srcdir}/autowaf"
+ git submodule update
+}
+
build() {
cd "${srcdir}/${_pkgname}"
@@ -36,7 +45,7 @@ build() {
--configdir=/etc \
--dyn-manifest \
--bindings
- python waf
+ python waf $MAKEFLAGS
}
package() {