summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Arndt2019-10-21 22:19:14 +0200
committerChristopher Arndt2019-10-21 22:19:14 +0200
commitbae9e6df76163b4794e7c4d95e44fd31abc3e960 (patch)
tree9c97120b1a48e95e425e5a85d0c42947a300f722 /PKGBUILD
parentf9486e1bb0a994b1b38463a86735c2f9bb9d98be (diff)
downloadaur-bae9e6df76163b4794e7c4d95e44fd31abc3e960.tar.gz
Remove obsolete '--bindings' waf option; build and run tests
Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c6cc26778542..e911577ac3bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgname=lilv
pkgname="${_pkgname}-git"
-pkgver=0.24.5.r1235.d959f44
+pkgver=0.24.5.r1240.7a7bff2
pkgrel=1
pkgdesc="A C library interface to the LV2 plug-in standard with Python bindings (git version)"
arch=('i686' 'x86_64')
@@ -38,6 +38,12 @@ prepare() {
git submodule update
}
+check() {
+ cd "${srcdir}/${_pkgname}"
+
+ python waf test -v -v
+}
+
build() {
cd "${srcdir}/${_pkgname}"
@@ -45,7 +51,7 @@ build() {
--prefix=/usr \
--configdir=/etc \
--dyn-manifest \
- --bindings
+ --test
python waf $MAKEFLAGS
}