summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Arndt2018-08-05 22:58:02 +0200
committerChristopher Arndt2018-08-05 22:58:02 +0200
commitd6983be3598f74273c72f29d20b2307aa96c9477 (patch)
tree43090e6e0ce29522dec1e6616b549bbddcc4f097 /PKGBUILD
parentce2d6b233d5d03fa62562fe2e45f107c0f70d95d (diff)
downloadaur-d6983be3598f74273c72f29d20b2307aa96c9477.tar.gz
Install bash completion
Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 50d885c4cbc6..863ec408375f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
_pkgname=lilv
pkgname="${_pkgname}-git"
pkgver=0.24.3.r1163.9a45b4c
-pkgrel=1
+pkgrel=2
pkgdesc="A C library interface to the LV2 plug-in standard"
arch=('i686' 'x86_64')
url="http://drobilla.net/software/lilv"
@@ -13,7 +13,7 @@ license=("custom:ISC")
depends=('lv2' 'python-numpy' 'sratom')
makedepends=('subversion' 'swig')
optdepends=(
- "bash-completion: auto-complete words"
+ "bash-completion: completion for bash"
"libsndfile: lv2apply utility"
)
provides=("${_pkgname}=${pkgver%.r*}")
@@ -43,5 +43,9 @@ package() {
cd "${srcdir}/${_pkgname}"
python waf install --destdir="${pkgdir}"
+ # license
install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ # bash completion
+ install -Dm644 utils/lilv.bash_completion -t \
+ "${pkgdir}/usr/share/bash-completion/completions/${_pkgname}"
}