summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhaawda2022-05-26 22:15:47 +0200
committerhaawda2022-05-26 22:15:47 +0200
commit18ede9b3e9415fe3d161e7f045da84c95a8c16d2 (patch)
treec888e2841ff457643f26da6511c46b131402b0a9 /PKGBUILD
parentdb8564720b8f254855aae5c931d354ac3e13837c (diff)
downloadaur-18ede9b3e9415fe3d161e7f045da84c95a8c16d2.tar.gz
pull from gitlab instaed savannah, and pull from branch=dev/wl/fix-install for now
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dab9528604fd..9af9e1ea0e37 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# delete the $srcdir directory before building
pkgname=lilypond-git
-pkgver=2.23b30044.1f4a63794d
+pkgver=2.23b31807.25ffd4b40d
pkgrel=1
pkgdesc="An automated music engraving system (Git snapshot)"
arch=('i686' 'x86_64')
@@ -23,14 +23,15 @@ makedepends=('fontforge'
'tex-gyre-fonts'
'texlive-langcyrillic'
'texi2html'
- 'netpbm')
+ 'netpbm'
+ 'python')
optdepends=('extractpdfmark: for reducing the size of pdf output significantly'
'tidy: same for HTML files'
'tk: for the gui')
provides=('lilypond')
conflicts=('lilypond')
-source=(git://git.savannah.gnu.org/lilypond.git)
-md5sums=('SKIP')
+source=(git+https://gitlab.com/lilypond/lilypond.git#branch=dev/wl/fix-install)
+sha256sums=('SKIP')
options=('!makeflags')
pkgver() {
@@ -46,12 +47,12 @@ build() {
./autogen.sh --noconfigure
[[ -d build ]] || mkdir build
cd build
- ../configure --prefix=/usr \
- --disable-documentation
+ ../configure --prefix=/usr --disable-documentation
make -j1
}
package() {
+ LANG=C
cd lilypond/build
make DESTDIR="$pkgdir/" vimdir="/usr/share/vim/vimfiles" install
rm -rf "$pkgdir"/usr/share/man