summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhaawda2022-05-28 20:41:53 +0200
committerhaawda2022-05-28 20:41:53 +0200
commit71862beab06c26f23d461b49703b193d49956dff (patch)
tree033119e583c170c5e5a3fee8cd09349c6dbb7260 /PKGBUILD
parent18ede9b3e9415fe3d161e7f045da84c95a8c16d2 (diff)
downloadaur-71862beab06c26f23d461b49703b193d49956dff.tar.gz
add patch, pull again from master
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9af9e1ea0e37..c49ce6ec2d44 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# delete the $srcdir directory before building
pkgname=lilypond-git
-pkgver=2.23b31807.25ffd4b40d
+pkgver=2.23b31827.8b533bda3b
pkgrel=1
pkgdesc="An automated music engraving system (Git snapshot)"
arch=('i686' 'x86_64')
@@ -30,8 +30,9 @@ optdepends=('extractpdfmark: for reducing the size of pdf output significantly'
'tk: for the gui')
provides=('lilypond')
conflicts=('lilypond')
-source=(git+https://gitlab.com/lilypond/lilypond.git#branch=dev/wl/fix-install)
-sha256sums=('SKIP')
+source=(git+https://gitlab.com/lilypond/lilypond.git fix_buildsystem.patch)
+sha256sums=('SKIP'
+ '4c04ea356f87321ab816ce25d28d3301698b8091df5f248f6bdc882cd9953f06')
options=('!makeflags')
pkgver() {
@@ -41,6 +42,11 @@ pkgver() {
"$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd lilypond/
+ patch -Np1 < "$srcdir"/fix_buildsystem.patch
+}
+
build() {
cd lilypond/
[[ -f config.hh ]] && rm config.hh
@@ -52,7 +58,6 @@ build() {
}
package() {
- LANG=C
cd lilypond/build
make DESTDIR="$pkgdir/" vimdir="/usr/share/vim/vimfiles" install
rm -rf "$pkgdir"/usr/share/man