summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhaawda2017-11-12 13:21:02 +0100
committerhaawda2017-11-12 13:21:02 +0100
commitf5996898befc6b468214c389c5ded02a7d91d629 (patch)
tree84d1e6e9abe1f34d96872da32d27baaa9d667dd7 /PKGBUILD
parent81425e0cf5ad6417fe079f0ff4d74dcadd2bafbd (diff)
downloadaur-f5996898befc6b468214c389c5ded02a7d91d629.tar.gz
rewrite pkgver function to reflect version jump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3b532aed7c09..4de2f9a2c787 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# delete the $srcdir directory before building
pkgname=lilypond-git
-pkgver=2.19.65.1.94.gabef0f722f
+pkgver=2.19.80.27998
pkgrel=1
pkgdesc="An automated music engraving system (Git snapshot)"
arch=('i686' 'x86_64')
@@ -20,13 +20,13 @@ optdepends=('imagemagick: building HTML documentation'
'extractpdfmark: for reducing the size of pdf output significantly')
provides=('lilypond')
conflicts=('lilypond' 'lilypond-devel')
-source=(git://git.sv.gnu.org/lilypond.git)
+source=(git://git.savannah.gnu.org/lilypond.git)
md5sums=('SKIP')
options=('!makeflags')
pkgver() {
cd lilypond/
- git describe | sed -e 's|release/\(.*\)|\1|' -e 's|-|.|g'
+ printf %s.%s $(grep VERSION_DEVEL VERSION | cut -d= -f2) $(git rev-list --count HEAD)
}
prepare() {