summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPierre Chapuis2017-01-30 15:45:10 +0100
committerPierre Chapuis2017-01-30 15:45:10 +0100
commitc86d238e78f89b2f16e20eff1ef4ed68a6cf778f (patch)
tree35c416d43cad01be538b6840e673a7d963bb460d /PKGBUILD
parent2d930b7ce248b35b1d067df93f110bbe1259fb5f (diff)
downloadaur-c86d238e78f89b2f16e20eff1ef4ed68a6cf778f.tar.gz
release v1.2beta
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7e43b0b9385e..751773c6080b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer: Pierre Chapuis <catwell at archlinux dot us>
pkgname=lima
-pkgver=1.1.1beta
+pkgver=1.2beta
pkgrel=1
pkgdesc="Personal Cloud software"
-depends=(python2 fuse)
+depends=(python2 fuse libyaml ffmpeg libjpeg-turbo)
optdepends=(
"python2-gnomekeyring: Gnome Keyring support"
"kdebindings-python2: KWallet support"
@@ -19,7 +19,7 @@ source=(
"lima.service"
)
sha256sums=(
- "02be5205081b22ca09fc9a7d1e0546e0f952ee15640aa6c6b0f2f40fe1871e61"
+ "ae49613d766dd1526cb09260db5d496b82d792ac83c12430a8e3bef7556aa914"
"68662c1437f88403f38b0e80da3b2b546512fe524b791cba27791cd2d5033e7c"
)
@@ -31,14 +31,19 @@ package() {
cp -r lib "$pkgdir/usr"
# Use python2 instead of python to make Namcap happy.
- sed -i -e "s|#!/usr/bin/env python$|#!/usr/bin/env python2|g" \
+ sed -i -e "s|#!/usr/bin/env python\r\?$|#!/usr/bin/env python2|g" \
+ $(find "$pkgdir" -name "*.py")
+ sed -i -e "s|#!/usr/local/bin/python\r\?$|#!/usr/bin/env python2|g" \
$(find "$pkgdir" -name "*.py")
# All .pyc files are OK.
find "$pkgdir" -name "*.pyc" -exec touch {} \;
- # Mark stack of library as non-executable.
+ # Mark stack of libraries as non-executable.
execstack -c "$pkgdir/usr/lib/lima/pylima.so"
+ for i in "$pkgdir/usr/lib/lima/deps/gnsdk/lib/linux_x86-64/"*".so"*; do
+ execstack -c "$i"
+ done
# Systemd unit file
install -Dm0644 "$srcdir/lima.service" \