summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRhinoceros2015-08-11 12:52:20 +1000
committerRhinoceros2015-08-11 12:52:20 +1000
commit5b5072b661b814be0ba9d872ef7a5463a899b108 (patch)
tree7787efa10b2a868aa34cc0c5b8150e745eef2f1f /PKGBUILD
parent193505aff20e35bd162d7407419f641a71715c33 (diff)
downloadaur-5b5072b661b814be0ba9d872ef7a5463a899b108.tar.gz
Update to 0.9.1-3
* Add correct package() function and clean up extraneous code * Correct makedepends and description * Use sha256sums, and other minor changes
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 17 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 128d9ef0da5a..e234ef20361f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,25 @@
+# Maintainer: Rhinoceros <https://aur.archlinux.org/account/rhinoceros>
# Contributor: Sergio Montesinos <sermonpe@yahoo.es>
pkgname=lingot
pkgver=0.9.1
-pkgrel=2
-pkgdesc="A Guitar tuner"
-url="http://www.nongnu.org/lingot/"
+pkgrel=3
+pkgdesc='A musical instrument tuner'
+url='http://www.nongnu.org/lingot/'
license=('GPL')
-arch=(i686 x86_64)
-depends=(gtk2 libglade jack)
-makedepends=('perlxml' 'intltool' 'gtk2')
-source=(http://download.savannah.gnu.org/releases/lingot/$pkgname-$pkgver.tar.gz)
-md5sums=('5a61c88e3770270246385ab9dbc39793')
+arch=('i686' 'x86_64')
+depends=('gtk2' 'libglade>=2.0.0' 'jack')
+makedepends=('perl-xml-parser' 'intltool' 'gtk2')
+source=("http://download.savannah.gnu.org/releases/lingot/$pkgname-$pkgver.tar.gz")
+sha256sums=('ec91223ab3df7c9160e6f1ededd8125e64764360caa0de39f54ef0668d56f979')
build() {
-cd $srcdir/$pkgname-$pkgver
-./configure --prefix=/usr
-make || return 1
-make DESTDIR=$pkgdir install
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
}